$re = '/26/im';
$str = 'test_farm_26
26_test_farm
a26
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);