$re = '/(?:(?<=^|[^\w])(?<!\@)\@)([\w\-.@]*[\w])(?=[^\w@]|$)(?!\@)/';
$str = 'Does @username works along with @username@example.com?';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);