re = /(?:(?<=^|[^\w])(?<!\@)\@)([\w\-.@]*[\w])(?=[^\w@]|$)(?!\@)/
str = 'Does @username works along with @username@example.com?'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end