re = /^ (JAN|FEB|MAR|APR|MAY|JUN|JUL|AUG|SEP|OCT|NOV|DEC) (MON|TUE|WED|THU|FRI|SAT|SUN) (19|20)\d\d $/m
str = ' FEB MON 2023 '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end