import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\s(\\w+)\\s+\\[?\\]?(\\w)(\\w+)\\s+`json:\"\\w+\"`";
final String string = " Author Author `json:\"author\"`\n"
+ " Footer Footer `json:\"footer\"`\n"
+ " Title string `json:\"title\"`\n"
+ " Description string `json:\"description\"`\n"
+ " Thumbnail Image `json:\"thumbnail\"`\n"
+ " Image Image `json:\"image\"`\n"
+ " URL string `json:\"url\"`\n"
+ " Fields []Field `json:\"fields\"`\n"
+ " Color int64 `json:\"color\"`";
final String subst = "func (b *EmbedB) $1(\\L$2\\E $2$3) *EmbedB {\\n\\tb.Embed.$1$2 = $2\\n\\treturn b\\n}";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}