re = /\s(\w+)\s+\[?\]?(\w)(\w+)\s+`json:"\w+"`/m
str = ' Author Author `json:"author"`
Footer Footer `json:"footer"`
Title string `json:"title"`
Description string `json:"description"`
Thumbnail Image `json:"thumbnail"`
Image Image `json:"image"`
URL string `json:"url"`
Fields []Field `json:"fields"`
Color int64 `json:"color"`'
subst = 'func (b *EmbedB) $1(\\L$2\\E $2$3) *EmbedB {\\n\\tb.Embed.$1$2 = $2\\n\\treturn b\\n}'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result