import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<img[^>]*(?=\\\"https?:\\/\\/(www\\.)?urpgstatic\\.com)\\\"([^\\\"]*)\\\"[^>]*>";
final String string = "<img src=\"https://www.pokeyplay.com/imagenes/backend/publicidad.gif\" alt=\"Publicidad\" align=\"left\" />\n"
+ "<img src=\"https://www.pokeyplay.com/imagenes/backend/spacer.gif\" alt=\"sp\" />\n"
+ "<img src=\"imagenes/backend/etiqueta-pyp-pokedex.gif\" alt=\"P&P PokéDex\" width=\"184\" height=\"100\" />\n"
+ "<img src=\"imagenes/backend/spacer.gif\" alt=\"sp\" />\n"
+ "<img src=\"http://urpgstatic.com/img_library/pokemon_sprites/187.png\" style=\"vertical-align:middle\" />\n\n"
+ "<img src=\"https://urpgstatic.com/images/pokemon-home.png\" alt=\"UnovaRPG (formerly Pokémon Indigo) - Online Pokemon Game\" width=\"250\" height=\"272\">";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}