# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"<img[^>]*(?=\"https?:\/\/(www\.)?urpgstatic\.com)\"([^\"]*)\"[^>]*>"
test_str = ("<img src=\"https://www.pokeyplay.com/imagenes/backend/publicidad.gif\" alt=\"Publicidad\" align=\"left\" />\n"
"<img src=\"https://www.pokeyplay.com/imagenes/backend/spacer.gif\" alt=\"sp\" />\n"
"<img src=\"imagenes/backend/etiqueta-pyp-pokedex.gif\" alt=\"P&P PokéDex\" width=\"184\" height=\"100\" />\n"
"<img src=\"imagenes/backend/spacer.gif\" alt=\"sp\" />\n"
"<img src=\"http://urpgstatic.com/img_library/pokemon_sprites/187.png\" style=\"vertical-align:middle\" />\n\n"
"<img src=\"https://urpgstatic.com/images/pokemon-home.png\" alt=\"UnovaRPG (formerly Pokémon Indigo) - Online Pokemon Game\" width=\"250\" height=\"272\">")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.