use strict;
my $str = 'NNNCTCGTNNNGTCGTN
';
my $regex = qr/\GN/mp;
my $subst = '-';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";