import re
regex = re.compile(r"\GN", flags=re.MULTILINE)
test_str = ("NNNCTCGTNNNGTCGTN\n")
subst = "-"
result = regex.sub(subst, test_str)
if result:
print(result)