import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:[^_]*_){3}([^_]+_[^_]+)_(?:[^_]+_){3}([^_]+_[^_]+).*";
final String string = "a_b_c_d_e_f_g_1_2_3_4_5\n"
+ "_b_c_dd_ee_f_g_1_222_333_4_5\n"
+ "b_c_dd_ee_f_g_1_222_333_4_5\n"
+ "_c_dd_ee_ff_g_1_222_333_444_5\n"
+ "c_dd_ee_ff_g_1_222_333_444_55_66\n"
+ "_dd_ee_ff_gg_1_222_333_444_55_66";
final String subst = "$1_$2";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}