package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)([^.]*\.)*([^_]*_[^_]*_[^_]*).*`)
var str = `ABC_Simple_DEF.dbo.GDE_1_1_Contact_test`
var substitution = "\2"
fmt.Println(re.ReplaceAllString(str, substitution))
}