$re = '/([^.]*\.)*([^_]*_[^_]*_[^_]*).*/m';
$str = 'ABC_Simple_DEF.dbo.GDE_1_1_Contact_test';
$subst = "\2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;