$re = '///([^:]*):/m';
$str = 'postgres://some-url.com:23244/users-pool?sslmode=require';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);