re = /\/\/([^:]*):/m
str = 'postgres://some-url.com:23244/users-pool?sslmode=require'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end