using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"User-Agent(?<ip>[^()]*\((?<device>[^()]*)\).*X-Forwarded-Proto)";
string input = @"User-Agent=Mozilla/5.0 (iPhone; CPU iPhone OS 15_1 like Mac OS X) AppleWebKit/605.1.15 (KHTML, like Gecko) Version/15.1 Mobile/15E148 Safari/604.1,X-Forwarded-Proto
User-Agent=Mozilla/5.0 (Macintosh; Intel Mac OS X 10_15_7) AppleWebKit/605.1.15 (KHTML, like Gecko) Version/14.1 Safari/605.1.15,X-Forwarded-Proto";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}