package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)User-Agent(?<ip>[^()]*\((?<device>[^()]*)\).*X-Forwarded-Proto)`)
var str = `User-Agent=Mozilla/5.0 (iPhone; CPU iPhone OS 15_1 like Mac OS X) AppleWebKit/605.1.15 (KHTML, like Gecko) Version/15.1 Mobile/15E148 Safari/604.1,X-Forwarded-Proto
User-Agent=Mozilla/5.0 (Macintosh; Intel Mac OS X 10_15_7) AppleWebKit/605.1.15 (KHTML, like Gecko) Version/14.1 Safari/605.1.15,X-Forwarded-Proto`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}