use strict;
my $str = '//check all zeros
0 0 0 0
0 0.0 0 0.0
0 0.000 0 0.000
0 0.0000 0 0.0000
//check plus and minus signs
+0 0 0 0
+0 0.0 0 0.0
+0 0.000 0 0.000
+0 0.0000 0 0.0000
0 0 +0 0
0 0.0 +0 0.0
0 0.000 +0 0.000
0 0.0000 +0 0.0000
+0 0 +0 0
+0 0.0 +0 0.0
+0 0.000 +0 0.000
+0 0.0000 +0 0.0000
-0 0 0 0
-0 0.0 0 0.0
-0 0.000 0 0.000
-0 0.0000 0 0.0000
0 0 -0 0
0 0.0 -0 0.0
0 0.000 -0 0.000
0 0.0000 -0 0.0000
-0 0 -0 0
-0 0.0 -0 0.0
-0 0.000 -0 0.000
-0 0.0000 -0 0.0000
';
my $regex = qr/^(([\+\-NnSs])?([0-8]?\d|90)[°˚º^~*\s\-_]+([0-5]?\d|\d)([.]\d*)?['′\s\-_]*([\+\-NnSs])?)([,:;\s|\/\\-]+)(([\+\-EeWw])?([0]?\d?\d|1[0-7]\d|180)[°˚º^~*\s\-_]+([0-5]\d|\d)([.]\d*)?['′\s_]*([\+\-EeWw])?)[\s]*$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}