import re
regex = re.compile(r"^(([\+\-NnSs])?([0-8]?\d|90)[°˚º^~*\s\-_]+([0-5]?\d|\d)([.]\d*)?['′\s\-_]*([\+\-NnSs])?)([,:;\s|\/\\-]+)(([\+\-EeWw])?([0]?\d?\d|1[0-7]\d|180)[°˚º^~*\s\-_]+([0-5]\d|\d)([.]\d*)?['′\s_]*([\+\-EeWw])?)[\s]*$", flags=re.MULTILINE)
test_str = ("//check all zeros\n"
"0 0 0 0\n"
"0 0.0 0 0.0\n"
"0 0.000 0 0.000\n"
"0 0.0000 0 0.0000\n\n"
"//check plus and minus signs\n"
"+0 0 0 0\n"
"+0 0.0 0 0.0\n"
"+0 0.000 0 0.000\n"
"+0 0.0000 0 0.0000\n\n"
"0 0 +0 0\n"
"0 0.0 +0 0.0\n"
"0 0.000 +0 0.000\n"
"0 0.0000 +0 0.0000\n\n"
"+0 0 +0 0\n"
"+0 0.0 +0 0.0\n"
"+0 0.000 +0 0.000\n"
"+0 0.0000 +0 0.0000\n\n"
"-0 0 0 0\n"
"-0 0.0 0 0.0\n"
"-0 0.000 0 0.000\n"
"-0 0.0000 0 0.0000\n\n"
"0 0 -0 0\n"
"0 0.0 -0 0.0\n"
"0 0.000 -0 0.000\n"
"0 0.0000 -0 0.0000\n\n"
"-0 0 -0 0\n"
"-0 0.0 -0 0.0\n"
"-0 0.000 -0 0.000\n"
"-0 0.0000 -0 0.0000\n\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")