package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:[a-f0-9]{2})*[a-f0-9](?:,(?:[a-f0-9]{2})*[a-f0-9])*$`)
var str = `aaffd,123,1,d3213,aaa,f
aaa,dd,1234,d,c
aaffd,123,1,d3213,aaa,f
1
2,345,1
ad,ad
1,23,1,333`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}