re = /^(?:[a-f0-9]{2})*[a-f0-9](?:,(?:[a-f0-9]{2})*[a-f0-9])*$/m
str = 'aaffd,123,1,d3213,aaa,f
aaa,dd,1234,d,c
aaffd,123,1,d3213,aaa,f
1
2,345,1
ad,ad
1,23,1,333'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end