package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[0-9]{2}(\.)[0-9]{3}(-)[0-9]$`)
var str = `00.000-0`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}