$re = '/^[0-9]{2}(\.)[0-9]{3}(-)[0-9]$/m';
$str = '00.000-0';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);