#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m).*martian.*source.*\n.*"
Local $sString = "Jan 10 11:08:21 server kernel: martian source 192.168.12.197 from 192.168.12.198, on dev eth0" & @CRLF & _
"Jan 11 10:12:45 server kernel: ll header: 08:00:00:00:45:00:01:00:00:00:40:00:40:11:9f:11:c0:a8:0c:c6:c0:a8:0c:c5" & @CRLF & _
"Jan 12 10:12:45 server kernel: lo: Disabled Priacy Extensions" & @CRLF & _
"Jan 13 10:12:45 server kernel: lo: Disabled Priacy Extensions" & @CRLF & _
"Jan 14 10:12:45 server kernel: lo: Disabled Priacy Extensions" & @CRLF & _
"Jan 15 10:12:45 server kernel: lo: Disabled Priacy Extensions" & @CRLF & _
"Jan 16 10:12:45 server kernel: lo: Disabled Priacy Extensions" & @CRLF & _
"Jan 17 10:12:45 server kernel: lo: Disabled Priacy Extensions" & @CRLF & _
"Jan 18 10:12:45 server kernel: lo: Disabled Priacy Extensions" & @CRLF & _
"Jan 19 10:12:45 server kernel: lo: Disabled Priacy Extensions" & @CRLF & _
"Jan 20 10:12:45 server kernel: lo: Disabled Priacy Extensions" & @CRLF & _
"Jan 21 10:12:45 server kernel: lo: Disabled Priacy Extensions" & @CRLF & _
"Jan 22 10:12:45 server kernel: lo: Disabled Priacy Extensions" & @CRLF & _
"Jan 23 10:12:45 server kernel: lo: Disabled Priacy Extensions" & @CRLF & _
"Jan 23 10:12:45 server kernel: lo: Disabled Priacy Extensions" & @CRLF & _
"Jan 24 10:12:45 server kernel: lo: Disabled Priacy Extensions" & @CRLF & _
"Jan 25 11:08:21 server kernel: martian source 192.168.12.197 from 192.168.12.198, on dev eth0" & @CRLF & _
"Jan 25 10:12:45 server kernel: ll header: 08:00:00:00:45:00:01:00:00:00:40:00:40:11:9f:11:c0:a8:0c:c6:c0:a8:0c:c5" & @CRLF & _
"Jan 26 11:08:21 server kernel: martian source 192.168.12.197 from 192.168.12.198, on dev eth0" & @CRLF & _
"Jan 26 10:12:45 server kernel: ll header: 08:00:00:00:45:00:01:00:00:00:40:00:40:11:9f:11:c0:a8:0c:c6:c0:a8:0c:c5" & @CRLF & _
"Jan 27 10:12:45 server kernel: lo: Disabled Priacy Extensions" & @CRLF & _
"Jan 28 11:08:21 server kernel: martian source 192.168.12.197 from 192.168.12.198, on dev eth0" & @CRLF & _
"Jan 28 10:12:45 server kernel: ll header: 08:00:00:00:45:00:01:00:00:00:40:00:40:11:9f:11:c0:a8:0c:c6:c0:a8:0c:c5"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")