const regex = /(.)\1/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(.)\\1', 'gm')
const str = `too many professionals`;
const subst = `$1$1$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);