use strict;
my $str = 'too many professionals';
my $regex = qr/(.)\1/mp;
my $subst = '$1$1$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";