#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^Plan A:\s+(?<plan_a>[\w\W]+?)\s+Plan B:\s+(?<plan_b>[\w\W]+?)\s+Plan C:\s+(?<plan_c>[\w\W]+)"
Local $sString = "Plan A: North Island Exploration" & @CRLF & _
"" & @CRLF & _
"Day 1: Explore Auckland" & @CRLF & _
"- Morning: Visit the Auckland War Memorial Museum" & @CRLF & _
"- Lunch: Try local cuisine at Depot Eatery & Oyster Bar" & @CRLF & _
"- Afternoon: Take a ferry to Waiheke Island for wine tasting" & @CRLF & _
"- Dinner: Dine at The Grove" & @CRLF & _
"- Accommodation: Rydges Auckland" & @CRLF & _
"- Estimated expenses: $150 per person" & @CRLF & _
"- Contingency plan: Visit indoor attractions in case of bad weather" & @CRLF & _
"" & @CRLF & _
"Day 2: Rotorua Adventure" & @CRLF & _
"- Morning: Visit Te Puia and see Pohutu Geyser" & @CRLF & _
"- Lunch: Have a traditional Maori lunch at Tamaki Maori Village" & @CRLF & _
"- Afternoon: Explore Wai-O-Tapu Thermal Wonderland" & @CRLF & _
"- Dinner: Enjoy a dinner cruise on Lake Rotorua" & @CRLF & _
"- Accommodation: Millennium Hotel Rotorua" & @CRLF & _
"- Estimated expenses: $200 per person" & @CRLF & _
"- Contingency plan: Visit a nearby spa for relaxation if outdoor activities are hindered by bad weather" & @CRLF & _
"" & @CRLF & _
"Day 3: Taupo and Tongariro National Park" & @CRLF & _
"- Morning: Take a cruise on Lake Taupo" & @CRLF & _
"- Lunch: Grab a bite at The Brantry" & @CRLF & _
"- Afternoon: Visit Tongariro National Park for hiking" & @CRLF & _
"- Dinner: Dine at Plateau Restaurant" & @CRLF & _
"- Accommodation: Suncourt Hotel & Conference Centre Taupo" & @CRLF & _
"- Estimated expenses: $180 per person" & @CRLF & _
"- Contingency plan: Explore local museums or go shopping in case of bad weather" & @CRLF & _
"" & @CRLF & _
"Day 4: Wellington City Tour" & @CRLF & _
"- Morning: Visit Te Papa Museum" & @CRLF & _
"- Lunch: Try local food at Ortega Fish Shack" & @CRLF & _
"- Afternoon: Explore Wellington Botanic Garden" & @CRLF & _
"- Dinner: Dine at Shed 5" & @CRLF & _
"- Accommodation: QT Wellington" & @CRLF & _
"- Estimated expenses: $160 per person" & @CRLF & _
"- Contingency plan: Visit art galleries or attend cultural performances indoors if outdoor sightseeing is not feasible" & @CRLF & _
"" & @CRLF & _
"Day 5: Return to Auckland" & @CRLF & _
"- Morning: Fly back to Auckland" & @CRLF & _
"- Lunch: Enjoy a meal at The Sugar Club overlooking the city" & @CRLF & _
"- Afternoon: Explore shopping at Queen Street" & @CRLF & _
"- Estimated expenses: $100 per person" & @CRLF & _
"- Contingency plan: Visit indoor markets or shopping centers if outdoor activities are limited" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"Plan B: South Island Adventure" & @CRLF & _
"" & @CRLF & _
"Day 1: Arrival in Queenstown" & @CRLF & _
"- Afternoon: Visit Skyline Queenstown for panoramic views" & @CRLF & _
"- Dinner: Dine at Rata Dining" & @CRLF & _
"- Accommodation: Novotel Queenstown Lakeside" & @CRLF & _
"- Estimated expenses: $150 per person" & @CRLF & _
"- Contingency plan: Explore local wineries or take a scenic drive in case of bad weather" & @CRLF & _
"" & @CRLF & _
"Day 2: Milford Sound" & @CRLF & _
"- Morning: Take a scenic bus tour to Milford Sound" & @CRLF & _
"- Lunch: Have a picnic at the waterfront" & @CRLF & _
"- Afternoon: Cruise through the fjords" & @CRLF & _
"- Dinner: Enjoy seafood at Fergburger" & @CRLF & _
"- Accommodation: Milford Sound Lodge" & @CRLF & _
"- Estimated expenses: $250 per person" & @CRLF & _
"- Contingency plan: Visit local museums or galleries if outdoor activities are not possible" & @CRLF & _
"" & @CRLF & _
"Day 3: Wanaka and Mount Aspiring National Park" & @CRLF & _
"- Morning: Visit Puzzling World in Wanaka" & @CRLF & _
"- Lunch: Dine at Urban Grind Cafe" & @CRLF & _
"- Afternoon: Explore Mount Aspiring National Park" & @CRLF & _
"- Dinner: Enjoy a meal at The Big Fig" & @CRLF & _
"- Accommodation: Edgewater Hotel" & @CRLF & _
"- Estimated expenses: $180 per person" & @CRLF & _
"- Contingency plan: Visit local cafes or bookstores for indoor relaxation if outdoor exploration is hampered by bad weather" & @CRLF & _
"" & @CRLF & _
"Day 4: Glacier Country" & @CRLF & _
"- Morning: Visit Fox Glacier and go hiking" & @CRLF & _
"- Lunch: Grab food at The Last Kitchen" & @CRLF & _
"- Afternoon: Explore Franz Josef Glacier" & @CRLF & _
"- Dinner: Dine at Alice May" & @CRLF & _
"- Accommodation: Scenic Hotel Franz Josef Glacier" & @CRLF & _
"- Estimated expenses: $200 per person" & @CRLF & _
"- Contingency plan: Visit local hot pools or spa for relaxation if outdoor activities are hindered by bad weather" & @CRLF & _
"" & @CRLF & _
"Day 5: Return to Queenstown" & @CRLF & _
"- Morning: Drive back to Queenstown" & @CRLF & _
"- Lunch: Eat at Botswana Butchery" & @CRLF & _
"- Afternoon: Visit Arrowtown for shopping" & @CRLF & _
"- Estimated expenses: $100 per person" & @CRLF & _
"- Contingency plan: Explore local art galleries or attend cultural performances indoors if outdoor activities are limited" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"Plan C: North and South Island Highlights" & @CRLF & _
"" & @CRLF & _
"Day 1: Arrival in Christchurch" & @CRLF & _
"- Afternoon: Visit the Canterbury Museum" & @CRLF & _
"- Dinner: Dine at Pescatore" & @CRLF & _
"- Accommodation: The George Christchurch" & @CRLF & _
"- Estimated expenses: $150 per person" & @CRLF & _
"- Contingency plan: Explore local cafes or bookstores if outdoor activities are hindered by bad weather" & @CRLF & _
"" & @CRLF & _
"Day 2: Arthur's Pass National Park" & @CRLF & _
"- Morning: Take a scenic drive to Arthur's Pass" & @CRLF & _
"- Lunch: Have a meal at the Alpine Restaurant" & @CRLF & _
"- Afternoon: Explore the national park and go hiking" & @CRLF & _
"- Dinner: Enjoy dinner at Devils Punchbowl Cafe" & @CRLF & _
"- Accommodation: Wilderness Lodge Arthur's Pass" & @CRLF & _
"- Estimated expenses: $200 per person" & @CRLF & _
"- Contingency plan: Visit local museums or galleries if outdoor activities are not possible" & @CRLF & _
"" & @CRLF & _
"Day 3: Marlborough Wine Region" & @CRLF & _
"- Morning: Drive to Marlborough region for wine tasting" & @CRLF & _
"- Lunch: Dine at Hans Herzog" & @CRLF & _
"- Afternoon: Visit vineyards for tasting" & @CRLF & _
"- Dinner: Enjoy a meal at Arbour" & @CRLF & _
"- Accommodation: Marlborough Vintners Hotel" & @CRLF & _
"- Estimated expenses: $180 per person" & @CRLF & _
"- Contingency plan: Visit a local market or shop for souvenirs in case of bad weather" & @CRLF & _
"" & @CRLF & _
"Day 4: Abel Tasman National Park" & @CRLF & _
"- Morning: Visit Abel Tasman National Park for kayaking" & @CRLF & _
"- Lunch: Grab a meal at Hooked on Marahau" & @CRLF & _
"- Afternoon: Explore the coastal trails" & @CRLF & _
"- Dinner: Dine at The Park Cafe" & @CRLF & _
"- Accommodation: Parklands Marina Holiday Park" & @CRLF & _
"- Estimated expenses: $220 per person" & @CRLF & _
"- Contingency plan: Visit local spas or hot pools for relaxation if outdoor activities are limited due to bad weather" & @CRLF & _
"" & @CRLF & _
"Day 5: Return to Christchurch" & @CRLF & _
"- Morning: Drive back to Christchurch" & @CRLF & _
"- Lunch: Eat at 27 Steps" & @CRLF & _
"- Afternoon: Explore Christchurch Botanic Gardens" & @CRLF & _
"- Estimated expenses: $100 per person" & @CRLF & _
"- Contingency plan: Visit local art galleries or attend cultural performances indoors if outdoor activities are not feasible."
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")