// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^Plan A:\s+(?<plan_a>[\w\W]+?)\s+Plan B:\s+(?<plan_b>[\w\W]+?)\s+Plan C:\s+(?<plan_c>[\w\W]+)").unwrap();
let string = "Plan A: North Island Exploration
Day 1: Explore Auckland
- Morning: Visit the Auckland War Memorial Museum
- Lunch: Try local cuisine at Depot Eatery & Oyster Bar
- Afternoon: Take a ferry to Waiheke Island for wine tasting
- Dinner: Dine at The Grove
- Accommodation: Rydges Auckland
- Estimated expenses: $150 per person
- Contingency plan: Visit indoor attractions in case of bad weather
Day 2: Rotorua Adventure
- Morning: Visit Te Puia and see Pohutu Geyser
- Lunch: Have a traditional Maori lunch at Tamaki Maori Village
- Afternoon: Explore Wai-O-Tapu Thermal Wonderland
- Dinner: Enjoy a dinner cruise on Lake Rotorua
- Accommodation: Millennium Hotel Rotorua
- Estimated expenses: $200 per person
- Contingency plan: Visit a nearby spa for relaxation if outdoor activities are hindered by bad weather
Day 3: Taupo and Tongariro National Park
- Morning: Take a cruise on Lake Taupo
- Lunch: Grab a bite at The Brantry
- Afternoon: Visit Tongariro National Park for hiking
- Dinner: Dine at Plateau Restaurant
- Accommodation: Suncourt Hotel & Conference Centre Taupo
- Estimated expenses: $180 per person
- Contingency plan: Explore local museums or go shopping in case of bad weather
Day 4: Wellington City Tour
- Morning: Visit Te Papa Museum
- Lunch: Try local food at Ortega Fish Shack
- Afternoon: Explore Wellington Botanic Garden
- Dinner: Dine at Shed 5
- Accommodation: QT Wellington
- Estimated expenses: $160 per person
- Contingency plan: Visit art galleries or attend cultural performances indoors if outdoor sightseeing is not feasible
Day 5: Return to Auckland
- Morning: Fly back to Auckland
- Lunch: Enjoy a meal at The Sugar Club overlooking the city
- Afternoon: Explore shopping at Queen Street
- Estimated expenses: $100 per person
- Contingency plan: Visit indoor markets or shopping centers if outdoor activities are limited
Plan B: South Island Adventure
Day 1: Arrival in Queenstown
- Afternoon: Visit Skyline Queenstown for panoramic views
- Dinner: Dine at Rata Dining
- Accommodation: Novotel Queenstown Lakeside
- Estimated expenses: $150 per person
- Contingency plan: Explore local wineries or take a scenic drive in case of bad weather
Day 2: Milford Sound
- Morning: Take a scenic bus tour to Milford Sound
- Lunch: Have a picnic at the waterfront
- Afternoon: Cruise through the fjords
- Dinner: Enjoy seafood at Fergburger
- Accommodation: Milford Sound Lodge
- Estimated expenses: $250 per person
- Contingency plan: Visit local museums or galleries if outdoor activities are not possible
Day 3: Wanaka and Mount Aspiring National Park
- Morning: Visit Puzzling World in Wanaka
- Lunch: Dine at Urban Grind Cafe
- Afternoon: Explore Mount Aspiring National Park
- Dinner: Enjoy a meal at The Big Fig
- Accommodation: Edgewater Hotel
- Estimated expenses: $180 per person
- Contingency plan: Visit local cafes or bookstores for indoor relaxation if outdoor exploration is hampered by bad weather
Day 4: Glacier Country
- Morning: Visit Fox Glacier and go hiking
- Lunch: Grab food at The Last Kitchen
- Afternoon: Explore Franz Josef Glacier
- Dinner: Dine at Alice May
- Accommodation: Scenic Hotel Franz Josef Glacier
- Estimated expenses: $200 per person
- Contingency plan: Visit local hot pools or spa for relaxation if outdoor activities are hindered by bad weather
Day 5: Return to Queenstown
- Morning: Drive back to Queenstown
- Lunch: Eat at Botswana Butchery
- Afternoon: Visit Arrowtown for shopping
- Estimated expenses: $100 per person
- Contingency plan: Explore local art galleries or attend cultural performances indoors if outdoor activities are limited
Plan C: North and South Island Highlights
Day 1: Arrival in Christchurch
- Afternoon: Visit the Canterbury Museum
- Dinner: Dine at Pescatore
- Accommodation: The George Christchurch
- Estimated expenses: $150 per person
- Contingency plan: Explore local cafes or bookstores if outdoor activities are hindered by bad weather
Day 2: Arthur's Pass National Park
- Morning: Take a scenic drive to Arthur's Pass
- Lunch: Have a meal at the Alpine Restaurant
- Afternoon: Explore the national park and go hiking
- Dinner: Enjoy dinner at Devils Punchbowl Cafe
- Accommodation: Wilderness Lodge Arthur's Pass
- Estimated expenses: $200 per person
- Contingency plan: Visit local museums or galleries if outdoor activities are not possible
Day 3: Marlborough Wine Region
- Morning: Drive to Marlborough region for wine tasting
- Lunch: Dine at Hans Herzog
- Afternoon: Visit vineyards for tasting
- Dinner: Enjoy a meal at Arbour
- Accommodation: Marlborough Vintners Hotel
- Estimated expenses: $180 per person
- Contingency plan: Visit a local market or shop for souvenirs in case of bad weather
Day 4: Abel Tasman National Park
- Morning: Visit Abel Tasman National Park for kayaking
- Lunch: Grab a meal at Hooked on Marahau
- Afternoon: Explore the coastal trails
- Dinner: Dine at The Park Cafe
- Accommodation: Parklands Marina Holiday Park
- Estimated expenses: $220 per person
- Contingency plan: Visit local spas or hot pools for relaxation if outdoor activities are limited due to bad weather
Day 5: Return to Christchurch
- Morning: Drive back to Christchurch
- Lunch: Eat at 27 Steps
- Afternoon: Explore Christchurch Botanic Gardens
- Estimated expenses: $100 per person
- Contingency plan: Visit local art galleries or attend cultural performances indoors if outdoor activities are not feasible.";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}