package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\d+|\b[a-zA-Z']+\b`)
var str = `testing, 1, 2 testing`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}