$re = '/\d+|\b[a-zA-Z\']+\b/m';
$str = 'testing, 1, 2 testing';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);