use strict;
my $str = 'com.atlassian.greenhopper.service.sprint.Sprint@1a671894[id=673,rapidViewId=21,state=CLOSED,name=Sprint_84,goal=,startDate=2016-10-03T09:21:27.008Z,endDate=2016-10-14T09:21:00.000Z,completeDate=2016-10-17T08:05:56.200Z,sequence=673],com.atlassian.greenhopper.service.sprint.Sprint@7b32d3f[id=665,rapidViewId=21,state=CLOSED,name=Sprint_83,goal=,startDate=2016-09-19T08:35:27.061Z,endDate=2016-09-30T08:35:00.000Z,completeDate=2016-10-03T08:15:20.694Z,sequence=665]';
my $regex = qr/name=Sprint_\d+/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}