# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"name=Sprint_\d+"
test_str = "com.atlassian.greenhopper.service.sprint.Sprint@1a671894[id=673,rapidViewId=21,state=CLOSED,name=Sprint_84,goal=,startDate=2016-10-03T09:21:27.008Z,endDate=2016-10-14T09:21:00.000Z,completeDate=2016-10-17T08:05:56.200Z,sequence=673],com.atlassian.greenhopper.service.sprint.Sprint@7b32d3f[id=665,rapidViewId=21,state=CLOSED,name=Sprint_83,goal=,startDate=2016-09-19T08:35:27.061Z,endDate=2016-09-30T08:35:00.000Z,completeDate=2016-10-03T08:15:20.694Z,sequence=665]"
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.