$re = '/name=Sprint_\d*/m';
$str = 'com.atlassian.greenhopper.service.sprint.Sprint@1a671894[id=673,rapidViewId=21,state=CLOSED,name=Sprint_,goal=,startDate=2016-10-03T09:21:27.008Z,endDate=2016-10-14T09:21:00.000Z,completeDate=2016-10-17T08:05:56.200Z,sequence=673],com.atlassian.greenhopper.service.sprint.Sprint@7b32d3f[id=665,rapidViewId=21,state=CLOSED,name=Sprint_,goal=,startDate=2016-09-19T08:35:27.061Z,endDate=2016-09-30T08:35:00.000Z,completeDate=2016-10-03T08:15:20.694Z,sequence=665]';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);