import Foundation
let pattern = #"name=Sprint_\d*"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"com.atlassian.greenhopper.service.sprint.Sprint@1a671894[id=673,rapidViewId=21,state=CLOSED,name=Sprint_,goal=,startDate=2016-10-03T09:21:27.008Z,endDate=2016-10-14T09:21:00.000Z,completeDate=2016-10-17T08:05:56.200Z,sequence=673],com.atlassian.greenhopper.service.sprint.Sprint@7b32d3f[id=665,rapidViewId=21,state=CLOSED,name=Sprint_,goal=,startDate=2016-09-19T08:35:27.061Z,endDate=2016-09-30T08:35:00.000Z,completeDate=2016-10-03T08:15:20.694Z,sequence=665]"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)