import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(Sent|Received).*?(\\d.*?(?:AM|PM))\\s(?:to\\s|from\\s)(\\w*?)\\n\\n([\\s\\S]*?)(?:\\n\\-{5}|$)[\\n\\S\\s]*?";
final String string = "Sent on 1/1/2023 7:30:33 AM to Person1\n\n"
+ "Message\n\n"
+ "-----\n\n"
+ "Received on 5/20/2023 4:55:33 PM from Person1\n\n"
+ "Message";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}