const regex = new RegExp('(Sent|Received).*?(\\d.*?(?:AM|PM))\\s(?:to\\s|from\\s)(\\w*?)\\n\\n([\\s\\S]*?)(?:\\n\\-{5}|$)[\\n\\S\\s]*?', 'g')
const str = `Sent on 1/1/2023 7:30:33 AM to Person1
Message
-----
Received on 5/20/2023 4:55:33 PM from Person1
Message`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}