$re = '/(?:(\()|({)|\[)(?(1)[^)\d]*\)|(?(2)[^}\d]*}|[^]\d]*]))\s*/m';
$str = '# (1437)
# {19} (917) (1437)
# {19} (1437) [1449] [2474] [2098] [1351] [508] [969]( MONDAY) [sunday]';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;