re = /^(?:\/MOTIF )(?<VALUE>.*)( \/BEN .*)?|^(?!\/MOTIF).+/m
str = '/MOTIF blablabla /BEN xxxxx….
blablablabla
/BEN blabla
/MO blabla'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end