#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?s)(\"\"\"|\'\'\'|\"|\')(?:\s*(SELECT)\s*\*\s*(SELECT|FROM))?(?:(?<!\\)\\\1|.)*?\1"
Local $sString = ""SELECT * FROM table"" & @CRLF & _
""" & @CRLF & _
" SELECT * FROM table"" & @CRLF & _
"" & @CRLF & _
""""" & @CRLF & _
"Use this query here: "SELECT * FROM table"" & @CRLF & _
""""" & @CRLF & _
"" & @CRLF & _
"SELECT * FROM table"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")