$re = '/(?s)(\"\"\"|\'\'\'|\"|\')(?:\s*(SELECT)\s*\*\s*(SELECT|FROM))?(?:(?<!\\\\)\\\\\1|.)*?\1/m';
$str = '"SELECT * FROM table"
"
SELECT * FROM table"
"""
Use this query here: "SELECT * FROM table"
"""
SELECT * FROM table';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);