const regex = /^(?=.{10,50}$)[a-zA-Z\s]*$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?=.{10,50}$)[a-zA-Z\\s]*$', '')
const str = `nguyenhuy `;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}