$re = '/^(?=.{10,50}$)[a-zA-Z\s]*$/';
$str = 'nguyenhuy ';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);