const regex = /([-_])([a-z])/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([-_])([a-z])', 'gm')
const str = `this-is-a-test`;
const subst = `$1$2`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);