$re = '/([-_])([a-z])/m';
$str = 'this-is-a-test';
$subst = "$1$2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;