package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\b(https?:\/\/[^ ]+)(\<br\>)`)
var str = `Webcam-Aufnahme https://www.edumaps.de/file?id=959559110184937375.mp4&code=4yrn1ev<br><b>test<b>`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}