const regex = /\b(https?:\/\/[^ ]+)(\<br\>)/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b(https?:\\\/\\\/[^ ]+)(\\<br\\>)', '')
const str = `Webcam-Aufnahme https://www.edumaps.de/file?id=959559110184937375.mp4&code=4yrn1ev<br><b>test<b>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}