import re
regex = re.compile(r"^([a-z])(?!\1)([a-z])(?!\1|\2)[a-z](?:1[5-9][0-9]{2}|20[01][0-9]|2020)[0-9]{2,4}[0-9]$", flags=re.MULTILINE)
test_str = ("abc1500999\n"
"abc15009999\n"
"abc150099999\n"
"abc202099999\n\n"
"bbc202099999\n"
"baa202099999")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")