re = /^([a-z])(?!\1)([a-z])(?!\1|\2)[a-z](?:1[5-9][0-9]{2}|20[01][0-9]|2020)[0-9]{2,4}[0-9]$/m
str = 'abc1500999
abc15009999
abc150099999
abc202099999
bbc202099999
baa202099999'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end