re = /[A-Z].*?[\.!?]/m
str = 'My name is UKKO. Nice to meet you. Have a Nice day!'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end