package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(www[.])?example[.]com`)
var str = `example.com -> www.example.net
www.example.com -> www.example.net
something.example.com
www
wwwexample.com
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}